summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorViktor Drobot2020-03-10 03:22:17 +0300
committerViktor Drobot2020-03-10 03:22:17 +0300
commit7ad62d9a61321da034ebd72e19cef9c20a56a20a (patch)
treec92d86d6fa0e1d5edd6dadd151babe6d3404d3a9 /PKGBUILD
parent51cf977143364e0426f715d58ab534b0ddedf990 (diff)
downloadaur-7ad62d9a61321da034ebd72e19cef9c20a56a20a.tar.gz
Fixed PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 21 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23212be970ed..0ab467d7169c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,31 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Kibouo <csonka.mihaly@hotmail.com>
# Contributor: Alex Branham <alex.branham@gmail.com>
-_cranver=1.7
+
_cranname=commonmark
-_pkgtar=${_cranname}_${_cranver}.tar.gz
-pkgname=r-commonmark
+_cranver=1.7
+pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc='High Performance CommonMark and Github Markdown Rendering in R'
-arch=('x86_64')
-url='https://cran.r-project.org/package=commonmark'
-license=('BSD_2_clause + file LICENSE')
-depends=('r' )
-optdepends=('r-curl')
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+pkgdesc="High Performance CommonMark and Github Markdown Rendering in R"
+arch=(i686 x86_64)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(BSD2)
+depends=(r)
+makedepends=(gcc)
+optdepends=(r-curl r-testthat r-xml2)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
md5sums=('48bf2251862a494d8ee3acde02dce385')
-build(){
- R CMD INSTALL commonmark_"$_cranver".tar.gz -l "$srcdir"
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
}
+
package() {
- install -dm0755 "$pkgdir"/usr/lib/R/library
- cp -a --no-preserve=ownership commonmark "$pkgdir"/usr/lib/R/library
-}
+ cd "${srcdir}"
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}