summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 07:02:58 +0800
committerSukanka2022-06-06 07:02:58 +0800
commit21bc17e5cbef80e8ead4a8eee50e2632b8ae6786 (patch)
tree82224fcf6f02c2aded2415a08ab3bd1b5e0fb172 /PKGBUILD
downloadaur-21bc17e5cbef80e8ead4a8eee50e2632b8ae6786.tar.gz
add r-consensusclusterplus
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65c0e0a72c8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=ConsensusClusterPlus
+_pkgver=1.60.0
+pkgname=r-${_pkgname,,}
+pkgver=1.60.0
+pkgrel=1
+pkgdesc='ConsensusClusterPlus'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-all
+ r-biobase
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('f7809db4eef81367be8b92b327e64dfd373e689893f0a99dd238e54a7a644180')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: