summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 07:04:08 +0800
committerSukanka2022-06-06 07:04:08 +0800
commit351ab2411619d4684ccaa3e037e34735edee430d (patch)
tree563fa42a7f06f24bf833b2018400c3c921d79554 /PKGBUILD
downloadaur-351ab2411619d4684ccaa3e037e34735edee430d.tar.gz
add r-consensusseeker
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48ed8e36daf9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=consensusSeekeR
+_pkgver=1.24.0
+pkgname=r-${_pkgname,,}
+pkgver=1.24.0
+pkgrel=1
+pkgdesc='Detection of consensus regions inside a group of experiences using genomic positions and genomic ranges'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-biocgenerics
+ r-biocparallel
+ r-genomeinfodb
+ r-genomicranges
+ r-iranges
+ r-rtracklayer
+ r-s4vectors
+ r-stringr
+)
+optdepends=(
+ r-biocstyle
+ r-ggplot2
+ r-knitr
+ r-rmarkdown
+ r-runit
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('23e493c809f76f5d474b501d5650c8cd2e3feece9d310ffb5b46ce7a32f581d9')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: