summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 07:11:09 +0800
committerSukanka2022-06-06 07:11:09 +0800
commit38801d33e8b001b05367d7c7d80d1c86078e1475 (patch)
tree2b16a6ecefc8432ecd944c83259148d97c7326f2 /PKGBUILD
downloadaur-38801d33e8b001b05367d7c7d80d1c86078e1475.tar.gz
add r-cormotif
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0980412703a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=Cormotif
+_pkgver=1.42.0
+pkgname=r-${_pkgname,,}
+pkgver=1.42.0
+pkgrel=1
+pkgdesc='Correlation Motif Fit'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-affy
+ r-limma
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('2359d455031eaf67e2ef9d7d4bb58fd28e9d4d93a70a9eac1ee2c583d24f8373')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: