summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 07:36:54 +0800
committerSukanka2022-06-06 07:36:54 +0800
commit605a86aee5b4394b7c0a831ea547e3383bbe34a6 (patch)
treedccc664e54e3051ec89a3494b23ddcd4357b7cd3 /PKGBUILD
downloadaur-605a86aee5b4394b7c0a831ea547e3383bbe34a6.tar.gz
add r-dapar
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD78
1 files changed, 78 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f98e74030843
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,78 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=DAPAR
+_pkgver=1.28.1
+pkgname=r-${_pkgname,,}
+pkgver=1.28.1
+pkgrel=3
+pkgdesc='Tools for the Differential Analysis of Proteins Abundance with R'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-annotationdbi
+ r-apcluster
+ r-biobase
+ r-cairo
+ r-clusterprofiler
+ r-cp4p
+ r-dapardata
+ r-dendextend
+ r-diptest
+ r-doparallel
+ r-dplyr
+ r-factoextra
+ r-factominer
+ r-forcats
+ r-foreach
+ r-ggplot2
+ r-gplots
+ r-graph
+ r-highcharter
+ r-igraph
+ r-imp4p
+ r-impute
+ r-knitr
+ r-limma
+ r-lme4
+ r-mfuzz
+ r-msnbase
+ r-multcomp
+ r-norm
+ r-openxlsx
+ r-pcamethods
+ r-png
+ r-preprocesscore
+ r-purrr
+ r-rcolorbrewer
+ r-readxl
+ r-reshape2
+ r-scales
+ r-siggenes
+ r-stringr
+ r-tibble
+ r-tidyr
+ r-tidyverse
+ r-tmvtnorm
+ r-vioplot
+ r-visnetwork
+ r-vsn
+)
+optdepends=(
+ r-biocgenerics
+ r-biocstyle
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('ae8c27c13843ce973d37cf34bf1782e35351d768822ccc432835f378e34f10e2')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: