summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 07:47:02 +0800
committerSukanka2022-06-06 07:47:02 +0800
commit9856fd90eefd2dfb87b8eb1da4ab227334142b38 (patch)
tree11d8f62a7166bf135c8161fb1a3b35c940e6716d /PKGBUILD
downloadaur-9856fd90eefd2dfb87b8eb1da4ab227334142b38.tar.gz
add r-deconvr
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68f314d37660
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=deconvR
+_pkgver=1.2.0
+pkgname=r-${_pkgname,,}
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='Simulation and Deconvolution of Omic Profiles'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-assertthat
+ r-biocgenerics
+ r-data.table
+ r-dplyr
+ r-e1071
+ r-foreach
+ r-genomicranges
+ r-iranges
+ r-magrittr
+ r-matrixstats
+ r-methylkit
+ r-nnls
+ r-quadprog
+ r-rsq
+ r-s4vectors
+ r-tidyr
+)
+optdepends=(
+ r-biocstyle
+ r-covr
+ r-devtools
+ r-doparallel
+ r-ggplot2
+ r-granulator
+ r-knitr
+ r-parallel
+ r-refmanager
+ r-reshape2
+ r-rmarkdown
+ r-roxygen2
+ r-sessioninfo
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('a3e6d733e1220482252d753a2e819d769fdc0e5fff0f23ffd64c57c52c1d3f24')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: