summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 07:52:06 +0800
committerSukanka2022-06-06 07:52:06 +0800
commite574e42f51797117a360222486d05c7bf33fab32 (patch)
treeb29a5dbbac8f19d92cc23f14b00c8271256766f0 /PKGBUILD
downloadaur-e574e42f51797117a360222486d05c7bf33fab32.tar.gz
add r-delayedrandomarray
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f5d8ccd06dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# system requirements: C++11
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=DelayedRandomArray
+_pkgver=1.4.0
+pkgname=r-${_pkgname,,}
+pkgver=1.4.0
+pkgrel=1
+pkgdesc='Delayed Arrays of Random Values'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-bh
+ r-delayedarray
+ r-dqrng
+ r-rcpp
+ gcc
+)
+optdepends=(
+ r-biocstyle
+ r-knitr
+ r-matrix
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('23e5f7c4ab3a60a4dabc3dfe93fc8a32d1c2f4b9c777ead06dae34b2b56be48d')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: