summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 07:54:12 +0800
committerSukanka2022-06-06 07:54:12 +0800
commit4f5dbaafbad7e19dff33337f9a4710d88752d568 (patch)
tree59931a5bcdac01da05919e81369e9caed27df969 /PKGBUILD
downloadaur-4f5dbaafbad7e19dff33337f9a4710d88752d568.tar.gz
add r-demixt
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b91ad7aac70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=DeMixT
+_pkgver=1.12.0
+pkgname=r-${_pkgname,,}
+pkgver=1.12.0
+pkgrel=1
+pkgdesc='Cell type-specific deconvolution of heterogeneous tumor samples with two or three components using expression data from RNAseq or microarray platforms'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-base64enc
+ r-ggplot2
+ r-knitr
+ r-matrixcalc
+ r-matrixstats
+ r-rcpp
+ r-rmarkdown
+ r-summarizedexperiment
+ r-truncdist
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('ce42e26ce92ffd15299325b9b72ef14d368544110b05310aa20540ab9bd1a687')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: