summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 08:10:11 +0800
committerSukanka2022-06-06 08:10:11 +0800
commit548d19ead3bd89c6d856aa8308f23e547e2a73e0 (patch)
treeeb510eb74212f71f1551760a05316b3d48e0d0f3 /PKGBUILD
downloadaur-548d19ead3bd89c6d856aa8308f23e547e2a73e0.tar.gz
add r-diffutr
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9de491e49e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=diffUTR
+_pkgver=1.4.0
+pkgname=r-${_pkgname,,}
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="diffUTR: Streamlining differential exon and 3' UTR usage"
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-complexheatmap
+ r-dexseq
+ r-dplyr
+ r-edger
+ r-ensembldb
+ r-genomeinfodb
+ r-genomicranges
+ r-ggplot2
+ r-ggrepel
+ r-iranges
+ r-limma
+ r-matrixstats
+ r-rsubread
+ r-rtracklayer
+ r-s4vectors
+ r-stringi
+ r-summarizedexperiment
+ r-viridislite
+)
+optdepends=(
+ r-biocstyle
+ r-knitr
+ r-rmarkdown
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('c50e0a87c209ee469d247306c9071ae0920860b062a5768c07fcd534debc0b05')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: