summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 08:40:40 +0800
committerSukanka2022-06-06 08:40:40 +0800
commit87cddbbcc0d3770f5e5e181f67ba06b5fe450193 (patch)
tree68b9f6ce8f4acd5378b808b6d3302ce198d62352 /PKGBUILD
downloadaur-87cddbbcc0d3770f5e5e181f67ba06b5fe450193.tar.gz
add r-dyebias
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5cf627446e0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=dyebias
+_pkgver=1.56.0
+pkgname=r-${_pkgname,,}
+pkgver=1.56.0
+pkgrel=1
+pkgdesc='The GASSCO method for correcting for slide-dependent gene-specific dye bias'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-biobase
+ r-marray
+)
+optdepends=(
+ r-convert
+ r-dyebiasexamples
+ r-geoquery
+ r-limma
+ r-methods
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('60781bf56e004dd2fe94edff8b6af13c2d98678eb100fc930fa36e32dfc39175')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: