summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWard Segers2018-12-18 00:03:07 +0100
committerWard Segers2018-12-18 00:03:07 +0100
commitb604a907f607ec6969965a45c2c72f328620d0e6 (patch)
treefae9121932f5954bcdb8f2ad8a05867599ec62f3 /PKGBUILD
downloadaur-b604a907f607ec6969965a45c2c72f328620d0e6.tar.gz
r-e1071
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0dd4567712c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Ward Segers <w@rdsegers.be>
+# Contributor: Alex Branham <alex.branham@gmail.com>
+
+_cranver=1.7-0
+pkgname=r-e1071
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc='Functions for latent class analysis, short time Fourier transform, fuzzy clustering, support vector machines, shortest path computation, bagged clustering, naive Bayes classifier, ...'
+arch=('x86_64')
+url='https://cran.r-project.org/web/packages/e1071'
+license=('GPL')
+depends=('r')
+replaces=('r-cran-e1071')
+source=("https://cran.r-project.org/src/contrib/e1071_"$_cranver".tar.gz")
+sha512sums=('SKIP')
+
+build(){
+ R CMD INSTALL e1071_"$_cranver".tar.gz -l "$srcdir"
+}
+
+package() {
+ install -dm0755 "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership e1071 "$pkgdir"/usr/lib/R/library
+}
+