summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-12-04 12:01:23 +0000
committerBioArchLinuxBot2023-12-04 12:01:23 +0000
commit7c596b790fa458378fcc0f98d7f2cfeb040bd4b1 (patch)
treed9d47da72441da730dbcc944495f2f0d118d28c5 /PKGBUILD
parent6e4b68c75a30b0631de924350478da2115c5a440 (diff)
downloadaur-r-ellipsis.tar.gz
[lilac] updated to 0.3.2-11
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 632a8c2b025f..87c3d2e05bf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _pkgname=ellipsis
_pkgver=0.3.2
pkgname=r-${_pkgname,,}
pkgver=${_pkgver//-/.}
-pkgrel=10
+pkgrel=11
pkgdesc="Tools for Working with ..."
arch=(x86_64)
url="https://cran.r-project.org/package=${_pkgname}"
@@ -15,6 +15,9 @@ license=(MIT)
depends=(
r-rlang
)
+checkdepends=(
+ r-testthat
+)
optdepends=(
r-covr
r-testthat
@@ -28,6 +31,11 @@ build() {
R CMD INSTALL "$_pkgname" -l build
}
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
package() {
install -d "$pkgdir/usr/lib/R/library"
cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"