summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 10:34:40 +0800
committerSukanka2022-06-06 10:34:40 +0800
commit87dfb6f006e5f36c173e5ce433b392914daeacb1 (patch)
tree8c1d5eff42c6a1e3702102a61c254473a59c4c6d /PKGBUILD
downloadaur-87dfb6f006e5f36c173e5ce433b392914daeacb1.tar.gz
add r-genenetworkbuilder
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c138ead560b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=GeneNetworkBuilder
+_pkgver=1.38.0
+pkgname=r-${_pkgname,,}
+pkgver=1.38.0
+pkgrel=1
+pkgdesc='GeneNetworkBuilder: a bioconductor package for building regulatory network using ChIP-chip/ChIP-seq data and Gene Expression Data'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-graph
+ r-htmlwidgets
+ r-plyr
+ r-rcpp
+ r-rgraphviz
+ r-rjson
+ r-xml
+)
+optdepends=(
+ r-biocgenerics
+ r-biocstyle
+ r-knitr
+ r-magick
+ r-rbgl
+ r-rmarkdown
+ r-runit
+ r-shiny
+ r-simpintlists
+ r-stringdb
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('28111ab8cab567bb408dc230c16b5e2c9bff8fc20b5c11a2a4e1d43970bae07b')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: