summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2019-02-09 14:14:44 +0000
committerGrey Christoforo2019-02-09 14:14:44 +0000
commitae61865d5478518454bed647ff938f09f8c5b025 (patch)
treefe4fb60b7aaf16a7ae70bc9ef8c2f396810a2939 /PKGBUILD
downloadaur-ae61865d5478518454bed647ff938f09f8c5b025.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e68371115ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Contributor: Grey Christoforo <first name at last name dot net>
+pkgname=r-genomeinfodb
+_bc_name=GenomeInfoDb
+pkgver=1.18.1
+pkgrel=1
+pkgdesc="Utilities for manipulating chromosome and other 'seqname' identifiers"
+url="https://bioconductor.org/packages/release/bioc/html/${_bc_name}.html"
+arch=("x86_64")
+license=('Artistic-2.0')
+depends=('r' 'r-genomeinfodbdata' 'r-iranges' 'r-biocgenerics' 'r-s4vectors' 'r-rcurl')
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_bc_name}_${pkgver}.tar.gz")
+sha1sums=('f198689ea484eb0dcb353a74d868638635dc4eae')
+
+package() {
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_bc_name}
+}