summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 10:49:44 +0800
committerSukanka2022-06-06 10:49:44 +0800
commit4e002075053915e7c1c8c217ca102b37f7af394d (patch)
treea0aafa58d220c618ab0de904b2e4ac5c189c2c3c /PKGBUILD
downloadaur-4e002075053915e7c1c8c217ca102b37f7af394d.tar.gz
add r-genphen
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9513243863c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=genphen
+_pkgver=1.24.0
+pkgname=r-${_pkgname,,}
+pkgver=1.24.0
+pkgrel=1
+pkgdesc='genphen: tool for quantification of genotype-phenotype associations in genome wide association studies (GWAS)'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-biostrings
+ r-doparallel
+ r-e1071
+ r-foreach
+ r-ranger
+ r-rcpp
+ r-rpref
+ r-rstan
+)
+optdepends=(
+ r-ape
+ r-ggplot2
+ r-ggrepel
+ r-gridextra
+ r-knitr
+ r-reshape
+ r-testthat
+ r-xtable
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('6805ee931998ad03305a3b56a3356502cb0519cf1bba2f3fe931eece9ec2c0d4')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: