diff options
author | BioArchLinuxBot | 2024-04-11 18:21:05 +0000 |
---|---|---|
committer | BioArchLinuxBot | 2024-04-11 18:21:05 +0000 |
commit | a6c86a9746d237f1419747458e0fb55cdd2a24e0 (patch) | |
tree | 40b37fb2e6fc30b4f039a2f3a60977948930ccaa /PKGBUILD | |
parent | d49d78cf030cba7f01cfd5f5445044f8ee6d3894 (diff) | |
download | aur-a6c86a9746d237f1419747458e0fb55cdd2a24e0.tar.gz |
[lilac] updated to 1.0.5-7
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 56 |
1 files changed, 40 insertions, 16 deletions
@@ -1,21 +1,25 @@ -# system requirements: Perl, Getopt::Long -# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net> +# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com> +# Contributor: Guoyi Zhang <guoyizhang at malacology dot net> _pkgname=GetoptLong _pkgver=1.0.5 pkgname=r-${_pkgname,,} -pkgver=1.0.5 -pkgrel=4 -pkgdesc='Parsing Command-Line Arguments and Simple Variable Interpolation' -arch=('any') -url="https://cran.r-project.org/package=${_pkgname}" +pkgver=${_pkgver//-/.} +pkgrel=7 +pkgdesc="Parsing Command-Line Arguments and Simple Variable Interpolation" +arch=(any) +url="https://cran.r-project.org/package=$_pkgname" license=('MIT') depends=( - r + perl-json + perl-json-xs + perl-yaml-syck r-crayon r-globaloptions r-rjson - perl +) +checkdepends=( + r-testthat ) optdepends=( r-knitr @@ -23,16 +27,36 @@ optdepends=( r-rmarkdown r-testthat ) -source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz") -sha256sums=('8c237986ed3dfb72d956ad865ef7768644eebf144675ad66140acfd1aca9d701') +source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz" + "fix-tests.patch") +md5sums=('859f5b437ccf1eda9fe0e99eb80b2def' + '2973d9109d39fe8fb5f1d3b93b7cb481') +b2sums=('e33d5c05f4a597144881cefdfcc1c96698136de1559797ac58a0e4f16cf92498e41407d3675fdebafef205379d17fba76f3354c25bbe509444c0afd0dc4e6b59' + 'fa9093742756bbc717c4702230155ff18358d209aa04bdce99940f717e19acdfe64bbfd5a46c7f9bda6ca767a376d5b9388c8c6029352ed27e2c539a4387e22d') + +prepare() { + # fix tests + patch -Np1 -i fix-tests.patch + + # use system perl modules + cd "$_pkgname/inst/extdata" + rm -r perl_lib +} build() { - R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}" + mkdir build + R CMD INSTALL -l build "$_pkgname" +} + +check() { + cd "$_pkgname/tests" + R_LIBS="$srcdir/build" NOT_CRAN=true GETOPTLONG_TESTING=true Rscript --vanilla test-all.R } package() { - install -dm0755 "${pkgdir}/usr/lib/R/library" - cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library" - install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}" + install -d "$pkgdir/usr/lib/R/library" + cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library" + + install -d "$pkgdir/usr/share/licenses/$pkgname" + ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname" } -# vim:set ts=2 sw=2 et: |