summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatt Frichtl2018-07-07 21:14:09 -0400
committerMatt Frichtl2018-07-07 21:14:09 -0400
commitd751327537667a92eb0f719ee527ffe20642db3b (patch)
tree36acd946dd082184fa45b36cd1feb25e12f15e09 /PKGBUILD
parent4dc4b3c560f962f74657b8e41a060f96ba955fc6 (diff)
downloadaur-d751327537667a92eb0f719ee527ffe20642db3b.tar.gz
updated to version 3.0.0. Added optional dependencies.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e3079883b2b..f36d90c4c32a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: frichtlm <frichtlm@gmail.com>
# Contributor: wagnerflo <florian@wagner-flo.net>
_cranname=ggplot2
-_cranver=2.2.1
+_cranver=3.0.0
pkgname=r-$_cranname
pkgver=${_cranver}
-pkgrel=2
+pkgrel=1
pkgdesc="Create Elegant Data Visualisations Using the Grammar of Graphics"
-url="http://cran.r-project.org/web/packages/${_cranname}/index.html"
+url="https://cran.r-project.org/package=ggplot2"
arch=('i686' 'x86_64')
license=('GPL-2')
-depends=('r>=3.1' 'r-digest' 'r-gtable>=0.1.1' 'r-plyr>=1.7.1' 'r-reshape2' 'r-scales>=0.4.1' 'r-tibble' 'r-lazyeval')
+depends=('r>=3.1' 'r-digest' 'r-gtable>=0.1.1' 'r-lazyeval' 'r-plyr>=1.7.1' 'r-reshape2' 'r-scales>=0.5.0' 'r-tibble' 'r-viridislite' 'r-withr>=2.0.0')
+optdepends=('r-covr' 'r-dplyr' 'r-ggplot2movies' 'r-hexbin' 'r-hmisc' 'r-mapproj' 'r-maps' 'r-maptools' 'r-multcomp' 'r-munsell' 'r-testthat' 'r-vdiffr' 'r-quantreg' 'r-knitr' 'r-rgeos' 'r-rpart' 'r-rmarkdown' 'r-svglite')
source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-md5sums=('14c5a3507bc123c6e7e9ad3bef7cee5c')
+md5sums=('95622cd0933f66865dc5e3a46f6fe18b')
package() {
mkdir -p ${pkgdir}/usr/lib/R/library