diff options
author | sukanka | 2022-07-21 22:51:43 +0800 |
---|---|---|
committer | sukanka | 2022-07-21 22:51:43 +0800 |
commit | fb37111dc9beb0a9c4f32aa0b0717a49161921c1 (patch) | |
tree | bf37ff3038888ebaf752125385c23829311e3214 /PKGBUILD | |
parent | aa35f59c03fa96637910b44f1e456c2cc56f6a05 (diff) | |
download | aur-fb37111dc9beb0a9c4f32aa0b0717a49161921c1.tar.gz |
takeover package
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 53 |
1 files changed, 38 insertions, 15 deletions
@@ -1,25 +1,48 @@ -# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com +# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net> -_cranname=ggpubr -_cranver=0.4.0 -pkgname=r-${_cranname,,} -pkgver=${_cranver//[:-]/.} -pkgrel=1 +_pkgname=ggpubr +_pkgver=0.4.0 +pkgname=r-${_pkgname,,} +pkgver=0.4.0 +pkgrel=3 pkgdesc="'ggplot2' Based Publication Ready Plots" -arch=(any) -url="https://cran.r-project.org/package=${_cranname}" -license=(GPL2) -depends=('r>=3.1.0' r-ggplot2 r-ggrepel r-ggsci r-tidyr r-purrr 'r-dplyr>=0.7.1' r-cowplot r-ggsignif r-scales r-gridextra r-glue r-polynom r-rlang 'r-rstatix>=0.6.0' r-tibble r-magrittr) -optdepends=(r-knitr r-rcolorbrewer r-gtable) -source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz") +arch=('any') +url="https://cran.r-project.org/package=${_pkgname}" +license=('GPL') +depends=( + r + r-cowplot + r-dplyr + r-ggplot2 + r-ggrepel + r-ggsci + r-ggsignif + r-glue + r-gridextra + r-magrittr + r-polynom + r-purrr + r-rlang + r-rstatix + r-scales + r-tibble + r-tidyr +) +optdepends=( + r-grdevices + r-gtable + r-knitr + r-rcolorbrewer +) +source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz") sha256sums=('abb21ec0b1ae3fa1c58eedca2d59b9b009621b30e3660f1247b3880c5fa50675') build() { - R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}" + R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}" } package() { install -dm0755 "${pkgdir}/usr/lib/R/library" - - cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library" + cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library" } +# vim:set ts=2 sw=2 et: |