summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 11:09:56 +0800
committerSukanka2022-06-06 11:09:56 +0800
commitfd0d7ce056cc8d68ef6daf927344e88b4543b876 (patch)
tree45e5b608c1391af574fbb532f1d1ccc631eaeb0b /PKGBUILD
downloadaur-fd0d7ce056cc8d68ef6daf927344e88b4543b876.tar.gz
add r-ggraph
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8bb977087b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=ggraph
+_pkgver=2.0.5
+pkgname=r-${_pkgname,,}
+pkgver=2.0.5
+pkgrel=4
+pkgdesc='An Implementation of Grammar of Graphics for Graphs and Networks'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('MIT')
+depends=(
+ r
+ r-digest
+ r-dplyr
+ r-ggforce
+ r-ggplot2
+ r-ggrepel
+ r-graphlayouts
+ r-gtable
+ r-igraph
+ r-rcpp
+ r-rlang
+ r-scales
+ r-tidygraph
+ r-viridis
+ r-withr
+)
+optdepends=(
+ r-covr
+ r-deldir
+ r-gganimate
+ r-knitr
+ r-network
+ r-purrr
+ r-rmarkdown
+ r-seriation
+ r-tibble
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('e36ad49dba92ee8652e18b1fb197be0ceb9f0a2f8faee2194453a62578449654')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: