summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 11:22:53 +0800
committerSukanka2022-06-06 11:22:53 +0800
commit09696106201125cfbe5e31412ecb4c490e10158c (patch)
tree190b0579e21dc915729179bf693c1f0b708c4115 /PKGBUILD
downloadaur-09696106201125cfbe5e31412ecb4c490e10158c.tar.gz
add r-gmedian
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef665fc2fee0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: sukanka <su975853527@gmail.com>
+
+_pkgname=Gmedian
+_pkgver=1.2.6
+pkgname=r-${_pkgname,,}
+pkgver=1.2.6
+pkgrel=5
+pkgdesc='Geometric Median, k-Medians Clustering and Robust Median PCA'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-rcpp
+ r-rcpparmadillo
+ r-robustbase
+ r-rspectra
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('ad48721ca190dc4bdf3af693c298843c605764b054ca03365d05d394930366cd')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: