summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 11:34:56 +0800
committerSukanka2022-06-06 11:34:56 +0800
commit804074982531911e740f607aa8c0811561737937 (patch)
treea2f47a6b112e7fbbecb663eaf6745ab4a355a36d /PKGBUILD
downloadaur-804074982531911e740f607aa8c0811561737937.tar.gz
add r-gotools
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..394eda8f76f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=goTools
+_pkgver=1.70.0
+pkgname=r-${_pkgname,,}
+pkgver=1.70.0
+pkgrel=1
+pkgdesc='Functions for Gene Ontology database'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-annotationdbi
+ r-go.db
+)
+optdepends=(
+ r-hgu133a.db
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('f7b1caeae533ff10c1ae66d110e4c9faffe97796125999d8e47403416ce6bdaf')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: