summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Fink2023-03-26 20:38:26 +0300
committerChristoph Fink2023-03-26 20:38:26 +0300
commit8c61daeea771e62316bc7d1b3c716db139b3b329 (patch)
tree8de348aea7ce817796de264162851a094edbc5ee /PKGBUILD
parent7f55fcff6c05986988ceccbef0ab17c28fcb0b6d (diff)
downloadaur-8c61daeea771e62316bc7d1b3c716db139b3b329.tar.gz
upgpkg: r-gtable 0.3.3-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 24 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 78742cbba552..95ce2550a132 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _cranname=gtable
_cranver=0.3.3
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
-pkgrel=1
+pkgrel=2
pkgdesc="Arrange ‘Grobs’ in Tables"
arch=("any")
url="https://cran.r-project.org/package=${_cranname}"
@@ -25,9 +25,25 @@ optdepends=(
"r-profvis"
"r-rmarkdown"
)
-checkdepends=(
- "r-testthat>=3.0.0"
-)
+
+# The unittests for `r-gtable` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-gtable`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat>=3.0.0"
+# )
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
b2sums=("11aaeac267036bb9de6e4fc5d7caff7dcf76b9421645393ccff4b1ac4624cd07e94707e5a43f70dcb029cb6df0671ce579a98acbff03eacdc76d07e5c6624582")
@@ -37,15 +53,14 @@ build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-check() {
- cd "${srcdir}/${_cranname}/tests"
- R_LIBS="${srcdir}/build" Rscript --vanilla testthat.R
-}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
-
if [[ -f "${_cranname}/LICENSE" ]]; then
install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
fi