summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Fink2024-04-23 13:14:58 +0200
committerChristoph Fink2024-04-23 13:14:58 +0200
commite2c616b30257d87dafdd6ddee09c7814b2ca1d2c (patch)
treec66bb388d64616d1a5797bda3911c470efacd6f9 /PKGBUILD
parent04022b27fbfe71de7c3f766b112b601c712ba2ba (diff)
downloadaur-e2c616b30257d87dafdd6ddee09c7814b2ca1d2c.tar.gz
upgpkg: r-gtable 0.3.5-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 083d4bec3d7f..fa4a53c69661 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Grey Christoforo <first name at last name dot net>
_cranname=gtable
-_cranver=0.3.4
+_cranver=0.3.5
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
@@ -40,23 +40,23 @@ optdepends=(
# the build chroot), uncomment the lines defining `checkdepends`, below,
# as well as the `check()` function further down
-checkdepends=(
- "${optdepends[@]}"
- "r-testthat>=3.0.0"
-)
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat>=3.0.0"
+# )
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-b2sums=("6c2975721cbbfbf3ebff542cbdc436f3302bd81e45be421bc9586364195e2c71a57b247b51ee13057d600e24147b5f80852a9b4dabc12144d8e9c0e0feba4e7b")
+b2sums=("4fbc57d8bcf2c2a0abe32cab3e1226ba6471df883439f2e9fa222615181067be0faa1423091a0341dbab0e5eb48ad297328bd0e9da598b00d92438450edbbbf5")
build() {
mkdir -p "${srcdir}/build/"
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-check() {
- export R_LIBS="build/"
- R CMD check --no-manual "${_cranname}"
-}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"