summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Fink2023-03-26 18:58:17 +0300
committerChristoph Fink2023-03-26 18:58:17 +0300
commit2e220e2315eb36a4c6f90e0615e0f701967eeea0 (patch)
treeb1cafa4abe338202c0ba0cf339c8f51c126b5dd6 /PKGBUILD
parent95d3a9986ae00d9d4f1ccbf0f1ef4530c044ddfa (diff)
downloadaur-2e220e2315eb36a4c6f90e0615e0f701967eeea0.tar.gz
upgpkg: r-gtfsio 1.1.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 26 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fbaafc8c0671..5ae15b9700da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="Read and Write General Transit Feed Specification (GTFS) Files"
url="https://cran.r-project.org/package=${_cranname}"
license=("MIT")
pkgver=${_cranver//[:-]/.}
-pkgrel=1
+pkgrel=2
arch=("any")
depends=(
@@ -19,29 +19,43 @@ optdepends=(
"r-knitr"
"r-rmarkdown"
)
-checkdepends=(
- "${optdepends[@]}"
- "r-rcmdcheck"
- "r-tinytest"
-)
+
+# The unittests for `r-gtfsio` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-gtfsio`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-rcmdcheck"
+# "r-tinytest"
+# )
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-b2sums=('43ed6035bcb68b1d42fab7eb6bf90f91dcb24317feca07d5a3b0c34d955ded7c0e14941288e92fb925ab16be8816a291dd471706ee09223d5ccb8ee32ecdfd60')
+b2sums=("43ed6035bcb68b1d42fab7eb6bf90f91dcb24317feca07d5a3b0c34d955ded7c0e14941288e92fb925ab16be8816a291dd471706ee09223d5ccb8ee32ecdfd60")
build() {
mkdir -p "${srcdir}/build/"
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-check() {
- cd "${srcdir}/${_cranname}/"
- R_LIBS="${srcdir}/build/" R CMD check --no-manual .
-}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
-
if [[ -f "${_cranname}/LICENSE" ]]; then
install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
fi