summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 12:08:21 +0800
committerSukanka2022-06-06 12:08:21 +0800
commit1eb232429f48de3de2139da2e3a5b9a856260273 (patch)
treef4787ca52218f86cc30936887919f5a7bc0bb591 /PKGBUILD
downloadaur-1eb232429f48de3de2139da2e3a5b9a856260273.tar.gz
add r-heatplus
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ba71a34a007
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=Heatplus
+_pkgver=3.4.0
+pkgname=r-${_pkgname,,}
+pkgver=3.4.0
+pkgrel=1
+pkgdesc='Heatmaps with row and/or column covariates and colored clusters'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-rcolorbrewer
+)
+optdepends=(
+ r-biobase
+ r-hgu95av2.db
+ r-limma
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('61c12945ed1d37cfe24892d3c555a5145ca4ec5507953bd2b511e7aa7dff352c')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: