summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 12:12:36 +0800
committerSukanka2022-06-06 12:12:36 +0800
commit8c3132cf7fdc39e87f94279d90f3097c6298ee12 (patch)
tree4fe6acf08e7c777a82926573a3c2833eb783e1e9 /PKGBUILD
downloadaur-r-hgu95av2.db.tar.gz
add r-hgu95av2.db
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c990ea14726a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=hgu95av2.db
+_pkgver=3.13.0
+pkgname=r-${_pkgname,,}
+pkgver=3.13.0
+pkgrel=4
+pkgdesc='Affymetrix Affymetrix HG_U95Av2 Array annotation data (chip hgu95av2)'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-annotationdbi
+ r-org.hs.eg.db
+)
+optdepends=(
+ r-annotate
+ r-dbi
+ r-runit
+)
+source=("https://bioconductor.org/packages/release/data/annotation/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('ff722f64852a02bcc2c31e5329847df3cb16796c327993f1525d7c74d3aa63fe')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: