summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-10-10 18:08:30 +0000
committerBioArchLinuxBot2023-10-10 18:08:30 +0000
commit78e425c2daa8345f7a3b3001c3080cdf3adb7c89 (patch)
treee56eaa2f8e6edb50e6b0456084b9d338eacb2702 /PKGBUILD
parent0abe3ba545da71f6f7d8fe6f80742fd61bb4f072 (diff)
downloadaur-78e425c2daa8345f7a3b3001c3080cdf3adb7c89.tar.gz
[lilac] updated to 1.36.4-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 24 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 678529c0e743..41e763739a68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,50 @@
-# system requirements: C++11, GNU make
-# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=HIBAG
_pkgver=1.36.4
pkgname=r-${_pkgname,,}
-pkgver=1.36.4
-pkgrel=1
-pkgdesc='HLA Genotype Imputation with Attribute Bagging'
-arch=('x86_64')
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="HLA Genotype Imputation with Attribute Bagging"
+arch=(x86_64)
url="https://bioconductor.org/packages/${_pkgname}"
-license=('GPL')
+license=(GPL3)
depends=(
- r
r-rcppparallel
- gcc
- make
+)
+checkdepends=(
+ r-gdsfmt
+ r-ggplot2
+ r-reshape2
+ r-snprelate
)
optdepends=(
r-gdsfmt
r-ggplot2
r-knitr
r-markdown
- r-parallel
r-reshape2
r-rmarkdown
+ r-rsamtools
r-seqarray
r-snprelate
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('db885989e0e66d6ddad9fa71425a34d2')
sha256sums=('8a5c38950418db1cd6ab9c017d4c7c715b31b4b94d878d17bd6219934e3b93b1')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" Rscript --vanilla runTests.R
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: