summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-07-02 12:08:12 +0000
committerBioArchLinuxBot2023-07-02 12:08:12 +0000
commit99402ab1613fe0763c3306ca9d0e1954bbe26418 (patch)
treef5628d808111281ce5da1bdb671a2b3fb9cc5456 /PKGBUILD
parent382467d78b397e08bfb83da922f19748d9f6af45 (diff)
downloadaur-99402ab1613fe0763c3306ca9d0e1954bbe26418.tar.gz
[lilac] updated to 1.6.11-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD64
1 files changed, 35 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0ca298769e63..14e63de40e63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,61 @@
# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
-_cranname=httpuv
-_cranver=1.6.11
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
+_pkgname=httpuv
+_pkgver=1.6.11
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=2
pkgdesc="HTTP and WebSocket Server Library"
-arch=(i686 x86_64)
-url="https://cran.r-project.org/package=${_cranname}"
+arch=(x86_64)
+url="https://cran.r-project.org/package=${_pkgname}"
license=(GPL)
depends=(
- libuv
- r-rcpp
- r-r6
- r-promises
- r-later
- zlib
+ libuv
+ r-later
+ r-promises
+ r-r6
+ r-rcpp
+ zlib
+)
+checkdepends=(
+ r-curl
+ r-testthat
+ r-websocket
)
-checkdepends=(r-curl r-testthat r-websocket)
optdepends=(
- r-testthat
- r-callr
- r-curl
- r-websocket
+ r-callr
+ r-curl
+ r-testthat
+ r-websocket
)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=('8ba79e0a8351274daf2dc566c71f88e891127cdedca62ad77a4b27a8103eeef5')
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz"
+ "system-libuv.patch")
+md5sums=('38ca2017f9a45faa2f45df08de147096'
+ 'f3a1ba807642c566ae7a47fd33fc9911')
+sha256sums=('8ba79e0a8351274daf2dc566c71f88e891127cdedca62ad77a4b27a8103eeef5'
+ '555ba06ceb96fe3d944ae189c07671034db6033b8bad61ce740f6cb44dbac855')
prepare() {
- # build against system libuv
- sed -i -e 's|PKG_LIBS = ./libuv/.libs/libuv.a|PKG_LIBS = -luv|' \
- -e 's|-Ilibuv/include ||' \
- -e 's|$(SHLIB): libuv/.libs/libuv.a|$(SHLIB):|' \
- "$_cranname/src/Makevars"
+ # build against system libuv and link to zlib
+ patch -Np1 -i system-libuv.patch
}
build() {
mkdir -p build
- R CMD INSTALL "$_cranname" -l build
+ R CMD INSTALL "$_pkgname" -l build
}
check() {
- cd "$_cranname/tests"
+ cd "$_pkgname/tests"
R_LIBS="$srcdir/build" LC_TIME=C NOT_CRAN=true Rscript --vanilla testthat.R
}
package() {
install -d "$pkgdir/usr/lib/R/library"
- cp -a --no-preserve=ownership "build/$_cranname" "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
install -d "$pkgdir/usr/share/licenses/$pkgname"
- ln -s "/usr/lib/R/library/$_cranname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
}