summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 12:31:56 +0800
committerSukanka2022-06-06 12:31:56 +0800
commit5cf9e664f05ecf2f69037c4895832f08a743ca37 (patch)
tree313fe8d7395a066ab374aa3822535c4e593bc61f /PKGBUILD
downloadaur-5cf9e664f05ecf2f69037c4895832f08a743ca37.tar.gz
add r-hyper
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..224d14f2c96e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=hypeR
+_pkgver=1.12.0
+pkgname=r-${_pkgname,,}
+pkgver=1.12.0
+pkgrel=1
+pkgdesc='An R Package For Geneset Enrichment Workflows'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-dplyr
+ r-ggforce
+ r-ggplot2
+ r-htmltools
+ r-httr
+ r-igraph
+ r-kableextra
+ r-magrittr
+ r-msigdbr
+ r-openxlsx
+ r-purrr
+ r-r6
+ r-reactable
+ r-reshape2
+ r-rlang
+ r-rmarkdown
+ r-scales
+ r-shiny
+ r-stringr
+ r-visnetwork
+)
+optdepends=(
+ r-devtools
+ r-knitr
+ r-testthat
+ r-tidyverse
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('444f162726c80637daa02719446b2752e6bd66d3052d3d609b43942d530865fa')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: