summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 13:08:33 +0800
committerSukanka2022-06-06 13:08:33 +0800
commit608e681f13fc06d6be1b98359d0dbbc299b4266d (patch)
tree0f8cc971d5e10283884206bbba8dfe65a5d4a2c9 /PKGBUILD
downloadaur-608e681f13fc06d6be1b98359d0dbbc299b4266d.tar.gz
add r-ipath
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a1bf84ed12d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# system requirements: C++11
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=iPath
+_pkgver=1.2.0
+pkgname=r-${_pkgname,,}
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='iPath pipeline for detecting perturbed pathways at individual level'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-biocparallel
+ r-ggplot2
+ r-ggpubr
+ r-matrixstats
+ r-mclust
+ r-rcpp
+ r-rcpparmadillo
+ r-survminer
+ gcc
+)
+optdepends=(
+ r-biocstyle
+ r-knitr
+ r-rmarkdown
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('1c4ef038ce63d99aa32028b008d1720fdacd39081bb6517f6f3e17e6861c7cbe')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: