summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 13:12:13 +0800
committerSukanka2022-06-06 13:12:13 +0800
commitac25df446ed2e7d57e0b99fa4dc7feed2bb70db2 (patch)
tree3e0e341bd37bbc8a8ef2441be99c404d64eb32cb /PKGBUILD
downloadaur-ac25df446ed2e7d57e0b99fa4dc7feed2bb70db2.tar.gz
add r-isee
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d369c79ddf84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=iSEE
+_pkgver=2.8.0
+pkgname=r-${_pkgname,,}
+pkgver=2.8.0
+pkgrel=1
+pkgdesc='Interactive SummarizedExperiment Explorer'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('MIT')
+depends=(
+ r
+ r-biocgenerics
+ r-circlize
+ r-colourpicker
+ r-complexheatmap
+ r-dt
+ r-ggplot2
+ r-ggrepel
+ r-igraph
+ r-rintrojs
+ r-s4vectors
+ r-shiny
+ r-shinyace
+ r-shinydashboard
+ r-shinyjs
+ r-shinywidgets
+ r-singlecellexperiment
+ r-summarizedexperiment
+ r-vipor
+ r-viridislite
+)
+optdepends=(
+ r-biocstyle
+ r-delayedarray
+ r-hdf5array
+ r-htmltools
+ r-knitr
+ r-rcolorbrewer
+ r-rmarkdown
+ r-scater
+ r-scrnaseq
+ r-tenxpbmcdata
+ r-testthat
+ r-viridis
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('f0cf783d15f0a1e720df000fe1ef25c816af316a498f1f31792510ede068b7ea')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: