summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-06-20 00:03:17 +0000
committerBioArchLinuxBot2023-06-20 00:03:17 +0000
commit77db6a29f417b066956ab01fcb143e6409a63768 (patch)
tree9faff4cb4e234a51bd5c7ee758fe9987d9a3f295 /PKGBUILD
parente7485455b70b86ef91d4c320de2478936b078a44 (diff)
downloadaur-77db6a29f417b066956ab01fcb143e6409a63768.tar.gz
[lilac] updated to 1.0.14-11
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 24 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 523765365e0d..082b8db54dd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,42 @@
# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Alex Branham <branham@utexas.edu>
-_cranname=iterators
-_cranver=1.0.14
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
+_pkgname=iterators
+_pkgver=1.0.14
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//[:-]/.}
+pkgrel=11
pkgdesc="Provides Iterator Construct"
arch=(any)
-url="https://cran.r-project.org/package=${_cranname}"
+url="https://cran.r-project.org/package=${_pkgname}"
license=(Apache)
-depends=(r)
-checkdepends=(r-runit)
-optdepends=(r-runit r-foreach)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+depends=(
+ r
+)
+checkdepends=(
+ r-runit
+)
+optdepends=(
+ r-foreach
+ r-runit
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('e1d875f0ddec6834dd33e56c4f04a706')
sha256sums=('cef3075a0930e1408c764e4da56bbadd4f7d14315809df8f38dd51f80ccc677b')
build() {
mkdir -p build
- R CMD INSTALL "${_cranname}" -l "${srcdir}/build"
+ R CMD INSTALL "$_pkgname" -l build
}
check() {
- cd "${_cranname}/tests"
- R_LIBS="${srcdir}/build" Rscript --vanilla doRUnit.R
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" Rscript --vanilla doRUnit.R
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
-
- cp -a --no-preserve=ownership "build/${_cranname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}