summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPekka Ristola2022-06-07 20:19:09 +0300
committerPekka Ristola2022-06-07 20:19:09 +0300
commite1613eaf388a724111f8f39773e48d4f17cabe37 (patch)
tree8bedaf99310c747d8ffaf755fbee80879115ff87 /PKGBUILD
parent505113a0469a54b1753df5534aa63ec91ca6d64a (diff)
downloadaur-e1613eaf388a724111f8f39773e48d4f17cabe37.tar.gz
Remove check() to avoid dependency cycle with r-testthat
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 1 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0b975b1f6c92..071abdd0a954 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,12 @@ _cranname=jsonlite
_cranver=1.8.0
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
-pkgrel=1
+pkgrel=2
pkgdesc="A Simple and Robust JSON Parser and Generator for R"
arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
license=(MIT)
depends=(r)
-checkdepends=(r-sf r-testthat)
optdepends=(
r-httr
r-curl
@@ -35,11 +34,6 @@ build() {
R CMD INSTALL "${_cranname}" -l "${srcdir}/build"
}
-check() {
- cd "${_cranname}/tests"
- R_LIBS="${srcdir}/build" NOT_CRAN=true Rscript --vanilla testthat.R
-}
-
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"