summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 13:46:04 +0800
committerSukanka2022-06-06 13:46:04 +0800
commit553e397cac27fbf96ae1a0e19168538a2f2191eb (patch)
treedb889a8cb578402625628e27dbaada804447e0ff /PKGBUILD
downloadaur-553e397cac27fbf96ae1a0e19168538a2f2191eb.tar.gz
add r-klar
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8450b5f2d5bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# system requirements: SVMlight
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=klaR
+_pkgver=1.7-0
+pkgname=r-${_pkgname,,}
+pkgver=1.7.0
+pkgrel=3
+pkgdesc='Classification and Visualization'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-combinat
+ r-questionr
+)
+optdepends=(
+ r-e1071
+ r-mlbench
+ r-rpart
+ r-scatterplot3d
+ r-som
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('b4795250ef19fd1b5e1b9a59343fd01159a33dbdbb504a06258220e37a718198')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: