summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Fink2023-03-26 18:59:12 +0300
committerChristoph Fink2023-03-26 18:59:12 +0300
commite117e6d97a7804e3e80ba3db738ed548b75f6ec5 (patch)
treecd85c2d949b716d1ae7d8b1f4b907ec2d77ee38a /PKGBUILD
parentc8cfce62e74a331874486e25a957ec7b36da893d (diff)
downloadaur-r-lazyeval.tar.gz
upgpkg: r-lazyeval 0.2.2-4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 24 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b3053021b3d5..8161b9fd72a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ pkgdesc="Lightweight Well-Known Geometry Parsing"
url="https://cran.r-project.org/package=${_cranname}"
license=("GPL3")
pkgver=${_cranver//[:-]/.}
-pkgrel=3
+pkgrel=4
arch=("i686" "x86_64")
depends=(
@@ -23,10 +23,25 @@ optdepends=(
"r-knitr"
"r-rmarkdown>=0.2.65"
)
-checkdepends=(
- "${optdepends[@]}"
- "r-testthat"
-)
+
+# The unittests for `r-lazyeval` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-lazyeval`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat"
+# )
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
b2sums=("94f69fe95a8ef8bf98421ae8570c6d381183f242e6f74334ed1886033b0ec3228e25b5412b89fe97fd4268f77b6be1c3fbe0113035b1afdee398898c732d67ff")
@@ -36,15 +51,14 @@ build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-check() {
- cd "${srcdir}/${_cranname}/tests"
- R_LIBS="${srcdir}/build/" Rscript --vanilla testthat.R
-}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
-
if [[ -f "${_cranname}/LICENSE" ]]; then
install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
fi