summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 14:18:06 +0800
committerSukanka2022-06-06 14:18:06 +0800
commit5178313ca2606047b0db233e96c6d75ee168374e (patch)
tree67cd4232b96fa673e54b40a82dc4e763a7c190be /PKGBUILD
downloadaur-5178313ca2606047b0db233e96c6d75ee168374e.tar.gz
add r-loose.rock
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85f46a54c6dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=loose.rock
+_pkgver=1.2.0
+pkgname=r-${_pkgname,,}
+pkgver=1.2.0
+pkgrel=4
+pkgdesc='Tools for Survival Analysis and Data Science'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-digest
+ r-dplyr
+ r-futile.options
+ r-ggplot2
+ r-httr
+ r-reshape2
+)
+optdepends=(
+ r-biomart
+ r-knitr
+ r-rmarkdown
+ r-roxygen2
+ r-survival
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('f934b6258ee7d8607fc8e3832d1855af769eff8382c8c7d962c34651d1ade38e')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: