summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPekka Ristola2022-11-06 12:49:51 +0200
committerPekka Ristola2022-11-06 12:49:51 +0200
commit00429223ecc890d611bbd8920c535bc5f51bd76f (patch)
tree3ebca9e01f006284b9890127523b361aa3db6117 /PKGBUILD
parent0368c66d3acfb254e8dc8f89b58c286ad8ba9026 (diff)
downloadaur-00429223ecc890d611bbd8920c535bc5f51bd76f.tar.gz
Update to 1.9.0
cctz is no longer included in the package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 4 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc0d85046459..615656944e83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,15 @@
# Contributor: wagnerflo <florian@wagner-flo.net>
_cranname=lubridate
-_cranver=1.8.0
+_cranver=1.9.0
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
-pkgrel=3
+pkgrel=1
pkgdesc="Make Dealing with Dates a Little Easier"
arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
license=(GPL)
-depends=(cctz r-generics)
-makedepends=(r-cpp11)
+depends=(r-timechange r-generics)
checkdepends=(r-testthat)
optdepends=(
r-covr
@@ -23,24 +22,14 @@ optdepends=(
r-rmarkdown
)
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=('87d66efdb1f3d680db381d7e40a202d35645865a0542e2f270ef008a19002ba5')
+sha256sums=('b936041f8a71894ef930cfff61b45833e0dd148b5b16697f4f541d25b31a903a')
prepare() {
cd "${_cranname}"
- # skip snapshot test that is incompatible with r-vctrs 0.4.1
- sed -i '/"vctrs methods have informative errors"/a\ \ skip("Incompatible with vctrs>=0.4.1")' \
- tests/testthat/test-vctrs.R
-
# skip test that requires a French locale
sed -i '/"parsing months with dots works in French linux locale"/a skip("Requires a French locale")' \
tests/testthat/test-parsers.R
-
- # build against system cctz
- sed -i -e 's|-I. -I./cctz/src/|-I.|' \
- -e 's/$(SHLIB): libcctz.a/$(SHLIB):/' \
- -e '/$(OBJECTS): libcctz.a/d' \
- src/Makevars
}
build() {