summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPekka Ristola2022-08-10 17:56:45 +0300
committerPekka Ristola2022-08-10 17:56:45 +0300
commit0368c66d3acfb254e8dc8f89b58c286ad8ba9026 (patch)
tree25dd0e874a3407ce9059932378a7f3bd0c136426 /PKGBUILD
parentd6aa4c86e29e1013a3ea6b4a82d5ba601321aa96 (diff)
downloadaur-0368c66d3acfb254e8dc8f89b58c286ad8ba9026.tar.gz
Fix tests to work with r-vctrs 0.4.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 198bdf51ebbb..fc0d85046459 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _cranname=lubridate
_cranver=1.8.0
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
-pkgrel=2
+pkgrel=3
pkgdesc="Make Dealing with Dates a Little Easier"
arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
@@ -28,6 +28,10 @@ sha256sums=('87d66efdb1f3d680db381d7e40a202d35645865a0542e2f270ef008a19002ba5')
prepare() {
cd "${_cranname}"
+ # skip snapshot test that is incompatible with r-vctrs 0.4.1
+ sed -i '/"vctrs methods have informative errors"/a\ \ skip("Incompatible with vctrs>=0.4.1")' \
+ tests/testthat/test-vctrs.R
+
# skip test that requires a French locale
sed -i '/"parsing months with dots works in French linux locale"/a skip("Requires a French locale")' \
tests/testthat/test-parsers.R