summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Fink2022-03-30 21:39:44 +0300
committerChristoph Fink2022-03-30 21:39:44 +0300
commit10dd02cc1b6f418cb5183e358ebd2abd55ef1dbd (patch)
tree23657f5227d5613d32aaec174291c4f980a6b8c0 /PKGBUILD
parent9dc739351d181a2d0506d7204c15ee97a3b92ccb (diff)
downloadaur-10dd02cc1b6f418cb5183e358ebd2abd55ef1dbd.tar.gz
upgpkg: r-magrittr 2.0.3-1
upstream release upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03377f56cd80..02af5935d8bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
+# Maintainer: peippo <christoph+aur@christophfink.com>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Grey Christoforo <first name at last name dot net>
_cranname=magrittr
-_cranver=2.0.2
+_cranver=2.0.3
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
@@ -10,10 +11,10 @@ pkgdesc="A Forward-Pipe Operator for R"
arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
license=(MIT)
-depends=(r)
+depends=("r>=3.4.0")
optdepends=(r-covr r-knitr r-rlang r-rmarkdown r-testthat)
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=('7be6fd0d0da75b92d8bad0136076da96260ee84bf639ef632a24668acdc163a6')
+sha256sums=("a2bff83f792a1acb801bfe6330bb62724c74d5308832f2cb6a6178336ace55d2")
build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
@@ -21,6 +22,9 @@ build() {
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
-
cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+
+ if [[ -f "${_cranname}/LICENSE" ]]; then
+ install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ fi
}