summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-12-26 00:10:09 +0000
committerBioArchLinuxBot2023-12-26 00:10:09 +0000
commit75b81d3fa4803ec5bd7f79defed1eb916bc1e572 (patch)
treee154e8ed6bcffa79bb2db27ac68cc2c3ca0593f4 /PKGBUILD
parentaef8a4fe4495d618b8ee1c2c162354dfaafb119f (diff)
downloadaur-r-matrixcalc.tar.gz
[lilac] updated to 1.0.6-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 39080c69e7d0..d0fe28d6054f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,25 @@
_pkgname=matrixcalc
_pkgver=1.0-6
pkgname=r-${_pkgname,,}
-pkgver=1.0.6
-pkgrel=1
-pkgdesc='Collection of Functions for Matrix Calculations'
-arch=('any')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+pkgver=${_pkgver//-/.}
+pkgrel=3
+pkgdesc="Collection of Functions for Matrix Calculations"
+arch=(any)
+url="https://cran.r-project.org/package=$_pkgname"
+license=(GPL)
depends=(
r
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('0bc7d2f11f62d8b1969474defe27c924a243ccba0c856d585f317f6caa07f326')
+md5sums=('3b7acd84cfbe8085fab05d2f40ff0c79')
+b2sums=('b9f4a3af74abf04c32bf9a3acaafa23cc6ea42fd45e79add4213c909501adaff4331947eeb925c1eec6f142d5dd8e75e92e675430de5ac6d793356e9a1df36c8')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: