summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 14:58:05 +0800
committerSukanka2022-06-06 14:58:05 +0800
commit421fa7831f6c5ca33b2a0266ecdfe080f8530672 (patch)
treed8b9b507ba81b6235a8b8e2afd6070b49419f113 /PKGBUILD
downloadaur-421fa7831f6c5ca33b2a0266ecdfe080f8530672.tar.gz
add r-mdqc
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19c8729b333f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=mdqc
+_pkgver=1.58.0
+pkgname=r-${_pkgname,,}
+pkgver=1.58.0
+pkgrel=1
+pkgdesc='Mahalanobis Distance Quality Control for microarrays'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('LGPL')
+depends=(
+ r
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('c54e23331c3b449dc1a20cf1cbc2450257cb24f55be9a690230631e881bb5a8c')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: