summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 15:17:20 +0800
committerSukanka2022-06-06 15:17:20 +0800
commitb08d76ff750a44a29da7f38f9cc4fed9d0d31cbc (patch)
treecc95b65bfe662bde692f56854e48b171aa733664 /PKGBUILD
downloadaur-b08d76ff750a44a29da7f38f9cc4fed9d0d31cbc.tar.gz
add r-metavizr
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9121ad4beeab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=metavizr
+_pkgver=1.20.0
+pkgname=r-${_pkgname,,}
+pkgver=1.20.0
+pkgrel=1
+pkgdesc='R Interface to the metaviz web app for interactive metagenomics data analysis and visualization'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('MIT')
+depends=(
+ r
+ r-biobase
+ r-data.table
+ r-digest
+ r-epivizr
+ r-epivizrdata
+ r-epivizrserver
+ r-epivizrstandalone
+ r-genomeinfodb
+ r-httr
+ r-metagenomeseq
+ r-phyloseq
+ r-vegan
+)
+optdepends=(
+ r-biocstyle
+ r-etec16s
+ r-experimenthub
+ r-gss
+ r-knitr
+ r-matrixstats
+ r-msd16s
+ r-rmarkdown
+ r-testthat
+ r-tidyr
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('3676eff172f6fab2477930059133b41ad80e3bb9edf43d64cc6e284314495f6a')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: