summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 16:28:27 +0800
committerSukanka2022-06-06 16:28:27 +0800
commitbcf20c5b9caa3316108d66387cb795cd5ba09dfd (patch)
treec6fc4b50cf66efd5abb03d2420e606f56a88cae4 /PKGBUILD
downloadaur-bcf20c5b9caa3316108d66387cb795cd5ba09dfd.tar.gz
add r-msstatslobd
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61758a29cd15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=MSstatsLOBD
+_pkgver=1.4.0
+pkgname=r-${_pkgname,,}
+pkgver=1.4.0
+pkgrel=1
+pkgdesc='Assay characterization: estimation of limit of blanc(LoB) and limit of detection(LOD)'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-ggplot2
+ r-minpack.lm
+ r-rcpp
+)
+optdepends=(
+ r-biocstyle
+ r-covr
+ r-dplyr
+ r-knitr
+ r-rmarkdown
+ r-tinytest
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('6250dccc2ea8fa668f5d1c58943e3b79f3f2b22c24d5670cbc4b742744f9ee9c')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: