summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPekka Ristola2023-12-11 13:37:21 +0200
committerPekka Ristola2023-12-11 13:37:21 +0200
commitf09a10991e75354b0baf73f8dc1c5b4ee6bd8b0f (patch)
tree58e4b46da444c17adc9d83edc89d7bee7780359e /PKGBUILD
downloadaur-f09a10991e75354b0baf73f8dc1c5b4ee6bd8b0f.tar.gz
Version 1.6.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9aa1f45121e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_pkgname=MuData
+_pkgver=1.6.0
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
+pkgdesc="Serialization for MultiAssayExperiment Objects"
+arch=(any)
+url="https://bioconductor.org/packages/${_pkgname}"
+license=(GPL3)
+depends=(
+ r-delayedarray
+ r-multiassayexperiment
+ r-rhdf5
+ r-s4vectors
+ r-singlecellexperiment
+ r-summarizedexperiment
+)
+checkdepends=(
+ r-hdf5array
+ r-testthat
+)
+optdepends=(
+ r-biocstyle
+ r-citefuse
+ r-covr
+ r-fs
+ r-hdf5array
+ r-knitr
+ r-rmarkdown
+ r-scater
+ r-singlecellmultimodal
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('10ef702e87a5f0517e59c1ccb96b08dc')
+sha256sums=('5d43b15ec405c0bc3cc1a328773fd76fda63f51555ec57ca10bafaec79dc2e3a')
+
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
+}
+
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
+}