summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 17:08:31 +0800
committerSukanka2022-06-06 17:08:31 +0800
commit72c171b06b6d6d1e33034de8ad22038717815b0f (patch)
tree4bf49205355e00b402da30e704be45740dfc8921 /PKGBUILD
downloadaur-72c171b06b6d6d1e33034de8ad22038717815b0f.tar.gz
add r-noiseq
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a005603b214
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=NOISeq
+_pkgver=2.40.0
+pkgname=r-${_pkgname,,}
+pkgver=2.40.0
+pkgrel=1
+pkgdesc='Exploratory analysis and differential expression for RNA-seq data'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-biobase
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('47cc6c13a1904f31f1b7ab206e438321208b6614d646ada72445900d6953062a')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: