summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Branham2018-06-07 14:00:35 -0500
committerAlex Branham2018-06-07 14:00:35 -0500
commit720953fa044bd8cf6321c84a2db1894ae5c993ce (patch)
tree7366aaf364b06cdff99a8b507a7b5296dc27c0c6 /PKGBUILD
downloadaur-720953fa044bd8cf6321c84a2db1894ae5c993ce.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfcaa82d422b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alex Branham <branham@utexas.edu>
+_cranname=openxlsx
+_cranver=4.1.0
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-openxlsx
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Read, Write and Edit XLSX Files"
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_cranname}"
+license=('MIT')
+depends=('r' 'r-zip')
+
+optdepends=('r-knitr' 'r-testthat')
+
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
+md5sums=('5fdee62e96b0d176419cacb5f7a6e125')
+
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
+package() {
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+}
+