summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 17:42:13 +0800
committerSukanka2022-06-06 17:42:13 +0800
commit345f73501b1bf7f6f339e34c600b5530617110c4 (patch)
tree09ea533ee6d518c3ad7a14b3e4081cd485a1d823 /PKGBUILD
downloadaur-345f73501b1bf7f6f339e34c600b5530617110c4.tar.gz
add r-org.mm.eg.db
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae5eacea6588
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=org.Mm.eg.db
+_pkgver=3.15.0
+pkgname=r-${_pkgname,,}
+pkgver=3.15.0
+pkgrel=3
+pkgdesc='Genome wide annotation for Mouse'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-annotationdbi
+)
+optdepends=(
+ r-annotate
+ r-dbi
+ r-runit
+)
+source=("https://bioconductor.org/packages/release/data/annotation/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('c658df080feb03fedfcbb5f772f3683ff7272b2de3deee055292005b3093d78a')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: