summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 17:39:49 +0800
committerSukanka2022-06-06 17:39:49 +0800
commite366f10cbc885b4586f75d9a3a65397ae4ea1fc3 (patch)
tree9d7c288ad44ef1837cb736ffd2751c7658ad7505 /PKGBUILD
downloadaur-e366f10cbc885b4586f75d9a3a65397ae4ea1fc3.tar.gz
add r-organism.dplyr
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a73f2747d1ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=Organism.dplyr
+_pkgver=1.24.0
+pkgname=r-${_pkgname,,}
+pkgver=1.24.0
+pkgrel=3
+pkgdesc='dplyr-based Access to Bioconductor Annotation Resources'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-annotationdbi
+ r-annotationfilter
+ r-biocfilecache
+ r-dbi
+ r-dbplyr
+ r-dplyr
+ r-genomeinfodb
+ r-genomicfeatures
+ r-genomicranges
+ r-iranges
+ r-rlang
+ r-rsqlite
+ r-s4vectors
+ r-tibble
+)
+optdepends=(
+ r-biocstyle
+ r-ggplot2
+ r-knitr
+ r-org.hs.eg.db
+ r-org.mm.eg.db
+ r-rmarkdown
+ r-testthat
+ r-txdb.hsapiens.ucsc.hg38.knowngene
+ r-txdb.mmusculus.ucsc.mm10.ensgene
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('5a95b2c081a4e9409980c716f576ade0df6dcee8fd0432382f8419d30a724948')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: