summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 17:39:23 +0800
committerSukanka2022-06-06 17:39:23 +0800
commitd9ad32e4436576c1460c5cf9f265c64d4c35367c (patch)
treeb347a94d829c02c1263916b01cd682ecda64134c /PKGBUILD
downloadaur-d9ad32e4436576c1460c5cf9f265c64d4c35367c.tar.gz
add r-organismdbi
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2083efaf3719
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=OrganismDbi
+_pkgver=1.38.0
+pkgname=r-${_pkgname,,}
+pkgver=1.38.0
+pkgrel=1
+pkgdesc='Software to enable the smooth interfacing of different database packages'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-annotationdbi
+ r-biobase
+ r-biocgenerics
+ r-biocmanager
+ r-dbi
+ r-genomicfeatures
+ r-genomicranges
+ r-graph
+ r-iranges
+ r-rbgl
+ r-s4vectors
+)
+optdepends=(
+ r-annotationhub
+ r-biomart
+ r-bsgenome.hsapiens.ucsc.hg19
+ r-fdb.ucsc.trnas
+ r-homo.sapiens
+ r-mirbase.db
+ r-rattus.norvegicus
+ r-rmariadb
+ r-rtracklayer
+ r-runit
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('d9b3e40d252a8d15c50c9444e147b10d3a6474c0d4852092d36957d27c5474f6')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: