summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSukanka2022-06-06 17:48:05 +0800
committerSukanka2022-06-06 17:48:05 +0800
commitae6737b9e9b3e55ac14c468049ffcad8087fc0e4 (patch)
tree6d8d37404e34e9afa6d0e9513a6e3d1a5e2d3912 /PKGBUILD
downloadaur-ae6737b9e9b3e55ac14c468049ffcad8087fc0e4.tar.gz
add r-packfinder
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6551e0dd32f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=packFinder
+_pkgver=1.8.0
+pkgname=r-${_pkgname,,}
+pkgver=1.8.0
+pkgrel=1
+pkgdesc='de novo Annotation of Pack-TYPE Transposable Elements'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-ape
+ r-biostrings
+ r-genomicranges
+ r-iranges
+ r-kmer
+ r-s4vectors
+)
+optdepends=(
+ r-bioccheck
+ r-biocstyle
+ r-biocviews
+ r-biomartr
+ r-dendextend
+ r-knitr
+ r-rmarkdown
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('f8e994f58d306a3132b7d81316bddb0cd50c098daa96f8eff5e1a0ce11e49b6b')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: